Diskussion:DevelopmentGuidelinesAV

Aus FHEMWiki
Wechseln zu: Navigation, Suche

Ich habe Einwände betreffend die Semantik der Befehle und Erläuterungen (Semantik ist mein Lehrgebiet).

1. volumeStraight ist nicht der richtige Ausdruck, es sollte volumeAbsolute heißen

2. channel darf sich nicht nur auf Fernsehkanäle beziehen, sondern muss allgemeiner sein (z.B. auch für DAB-Systeme)

3. off schaltet des Gerät keinesfalls so aus, dass es nicht mehr benutzt werden kann. Denn es ist immer noch einschaltbar.

4. Ein reading "power" sollte es nicht geben. Das ist nämlich reserviert für die elektrische Leistung. Sollte also hier z.B. umbenannt werden in ONOFF.

5. Default-Attribut für alle Schalter (sowohl mute, als auch schuffle) sollte "toggle" sein, ohne dass man dies jeweils angeben muss.

LG

--Pahenning (Diskussion) 15:25, 23. Jan. 2014 (CET)

  1. ja. das ist besser
  2. hier ist eigentlich eher ein laufender stations oder programm speicher platz gemeint. ich habe es in diesem sinne geändert.
  3. es ist vermutlich zu gerätespezfisch das genauer fassen zu wollen. ich habe den satzteil entfernt.
  4. wenn man die developer seiten und die interfaces als anhaltspunkt nimmt sollte es klein geschrieben onoff sein. wobei ich es für nicht besonders glücklich und lesbar halte. es ist auch nicht ansatzweise ein richtiges wort. standby wäre besser. hat aber eine invertierte bedeutung.
  5. "toggle" bei shuffle noch hinzuzufügen finde ich gut.
den vorteil ein default verhalten zu haben ohne das arguement angeben zu müssen sehe ich aber nicht.
und wenn es um die semantik geht: ein 'set <device> mute' oder 'set <device> shuffle' würden vermutlich die aller meisten eher im sinne von 'diese funktion aktivieren' verstehen ist und nicht im sinne von 'diese funtlion umschalten'.

--Justme (Diskussion) 18:55, 23. Jan. 2014 (CET)

  1. volumeStraight ist auf meine Kappe gewachsen. Bin eh am überlegen, das Reading/Kommando nicht ganz zu begraben und nur noch in Prozentwerten zu arbeiten. Alternativ finde ich den Vorschlag von pah aber gut.
  2. ...
  3. Im Sinne der Semantik ist das durchaus richtig. Ist aber auch wieder sehr Geräteabhängig. Natürlich werden viele Geräte bei "off" in einem minimalen Network-Standby sein, aber dennoch die Funktion einstellen. Die einen Geräte können nicht weiter "ausgeschaltet" werden als dieser NetworkStandby, andere können es wieder. Wenn es danach geht müssten alle Multimedia-Geräte statt "off" im state "standby" sein. Würde ich aber in der FHEM-Welt vermeiden hier wieder eine Extrawurst zu erschaffen.
  4. "ONOFF" (egal in welcher Groß-/Klein-Schreibweise) finde ich verwirrend. Wie währe es mit "powerState", oder etwas ähnlichem?
  5. Ein Defaultattribut finde ich falsch, hier stimme ich Justme's Erklärung zu. Das toggle-Kommando aber als ersten verfügbaren Parameter in der FHEMWEB-GUI anbieten, währe eine Möglichkeit.

--Markus Bloch (Diskussion) 19:39, 24. Jan. 2014 (CET)

Der Zustand nach einem "Soft Off" wird in der Regel so sein, dass auch wieder ein "Soft On" gemacht werden kann - und nicht nur ein "Hard Off". Damit ist das Gerät aber "verwendbar".

"powerState" heißt "Leistungszustand" und beschreibt es auch nicht besser. "Zustand" an sich ist schon gut, führt aber beim FHEM wegen der state-Variablen zur Verwirrung. Ideal wäre das gute deutsche Wort "Betriebszustand", zu übersetzen mit "operationalState" oder "opState" - von mir aus auch "operation" und den möglichen Werten

Run (oder Running) Standby SoftOff HardOff

--Pahenning (Diskussion) 10:18, 28. Jan. 2014 (UTC)